How can we improve Bing Ads to create a better experience?

Please FINALLY add a user interface language selector to Bing Ads Editor.

We are an international company, and you are making it impossible for me to share my screen with my colleagues, as they don't speak German (OS Language). Bing Editor should allow to select the display (UI) language.

6 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Thomas Widter shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    Devang Gandhi responded  · 

    Hi Thomas,

    Thanks for your feedback. We are currently looking into exposing the capability to change the UI language. In the meanwhile, here’s a workaround that you can use.

    1. Navigate to localappdata\Bing Ads Editor folder on your machine
    2. Open the Microsoft.AdvertisingDesktop.exe.config file
    3. Add key=“ShowCultureOptions” value=“True” under the appSettings section
    4. Restart Bing Ads Editor
    5. Go to Tools > Options > MSFT Internal Setup. From here you will be able to change the UI language

    Note that the editor will take into account even the date, time and number formats of the locale that you select from the drop down.

    Hope this helps!

    4 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Frank commented  ·   ·  Flag as inappropriate

        Hi,

        I tried the instructions you have provided to change the UI language from French to English, but there isn't even English as a language option. I tried to change it to other languages, but the system simply reset itself back to French. Am I missing something here? Thank you for your kind assistance on this matter.

        Frank

      • AdminDevang Gandhi (Admin, Bing Ads) commented  ·   ·  Flag as inappropriate

        Hi Thomas,

        The key-value pair was being interpreted as html element and was hidden from my response. I've fixed it now, please refer to my earlier response. Apologize for the inconvenience. Let me know if you have any questions.

        Thanks!

      • Thomas Widter commented  ·   ·  Flag as inappropriate

        Hey Devang, thanks for getting back to me on this! Regarding point 3 in your list - what should I add to the config file? BR, Thomas

      Feedback and Knowledge Base